[Webkit-unassigned] [Bug 55416] Viewport no longer allows an auto value for "user-scalable"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 8 00:59:02 PST 2011


--- Comment #7 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2011-03-08 00:59:01 PST ---
(In reply to comment #5)
> > Source/WebKit2/UIProcess/API/qt/qwkpage.cpp:564:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
> Bah, I just wanted to be explicit about the conversion from non-zero to true.
> Since possible values are -1, 0, and 1, it seems weird to me here to do
> static_cast<bool>(someFloat), but I could do that. Same with !0.

The coding style is educational and a guide line. If it makes sense you are allowed to divert from it, though I think !0 would be fine here.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list