[Webkit-unassigned] [Bug 63706] [GTK] Implement drag and drop support in WebKit2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 30 09:09:13 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=63706


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mrobinson at webkit.org




--- Comment #8 from Martin Robinson <mrobinson at webkit.org>  2011-06-30 09:09:13 PST ---
(In reply to comment #7)

> > >> Source/WebKit2/Shared/gtk/ArgumentCodersGtk.cpp:113
> > >> +static bool decodeDataObject(ArgumentDecoder* decoder, RefPtr<DataObjectGtk>& dataObject)
> > > 
> > > The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
> > 
> > It's pretty weird to pass a reference to a RefPtr here. You should just use a PassRefPtr.
> 
> See decodeImage in Source/WebKit2/Shared/WebCoreArgumentCoders.cpp:
> static bool decodeImage(ArgumentDecoder* decoder, RefPtr<Image>& image)

WebKit as a project has recently become more strict about RefPtr/PassRefPtr usage. Perhaps there was some reason it wasn't possible in that case, but my instinct says this should just be a PassRefPtr.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list