[Webkit-unassigned] [Bug 62098] Update layout for msub, msup, msubsup to handle script changes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jun 5 08:43:12 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62098


Kenneth Rohde Christiansen <kenneth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #96035|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #4 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2011-06-05 08:43:12 PST ---
(From update of attachment 96035)
View in context: https://bugs.webkit.org/attachment.cgi?id=96035&action=review

> Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:66
> +    int position = 0;

unsigned?

> Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:68
> +        if (current->nodeType() == Node::ELEMENT_NODE)

Isnt there an isElementNode() ? im pretty sure that exists

> Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:176
> -            int heightDiff = m_scripts ? (m_scripts->offsetHeight() - maxHeight) / 2 : 0;
> +            int heightDiff = m_scripts ?
> +                (m_scripts->offsetHeight() - maxHeight) / 2 
> +                : 0;

Im not sure what our style guide says, but I havent run into this style before. I would just keep it on one line

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list