[Webkit-unassigned] [Bug 62098] Update layout for msub, msup, msubsup to handle script changes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jun 5 08:53:49 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62098





--- Comment #5 from Alex Milowski <alex at milowski.com>  2011-06-05 08:53:49 PST ---
(In reply to comment #4)
> (From update of attachment 96035 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=96035&action=review
> 
> > Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:66
> > +    int position = 0;
> 
> unsigned?

OK.

> 
> > Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:68
> > +        if (current->nodeType() == Node::ELEMENT_NODE)
> 
> Isnt there an isElementNode() ? im pretty sure that exists

Yes, there is.  I'll switch to that.

> 
> > Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:176
> > -            int heightDiff = m_scripts ? (m_scripts->offsetHeight() - maxHeight) / 2 : 0;
> > +            int heightDiff = m_scripts ?
> > +                (m_scripts->offsetHeight() - maxHeight) / 2 
> > +                : 0;
> 
> Im not sure what our style guide says, but I havent run into this style before. I would just keep it on one line

The current style check script incorrectly identifies this as a bit field.  I filed a bug 62097 on this.  Meanwhile, this is the only way to get around the style check script.  I'd rather not make this change but I certainly don't want to wait for someone to fix that script.

I'd love another way to commit this patch.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list