[Webkit-unassigned] [Bug 64580] Add support for download='filename' in anchors
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sat Jul 23 17:37:23 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=64580
--- Comment #61 from sadrul at chromium.org 2011-07-23 17:37:23 PST ---
(From update of attachment 101763)
View in context: https://bugs.webkit.org/attachment.cgi?id=101763&action=review
>> Source/WebCore/loader/FrameLoaderClient.h:182
>> + virtual void startDownload(const ResourceRequest&, const String& = String()) = 0;
>
> This argument definitely needs a name.
Added name.
>> Source/WebKit2/WebProcess/WebCoreSupport/WebFrameLoaderClient.cpp:795
>> }
>
> How doesn't this unused argument no break the build? Ditto elsewhere.
I think -Wno-unused-parameter flag is used for compiling? I have put the variable name in a /* comment since that style seems to be used in a few places in WebKit to avoid the issue.
>> Source/WebKit2/WebProcess/WebPage/WebFrame.h:73
>> + void startDownload(const WebCore::ResourceRequest&, const String& = String());
>
> I guess it's not a big deal to modify to WebFrame, but it doesn't seem necessary.
I have removed this from here.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list