[Webkit-unassigned] [Bug 64786] The value of a number input form continues to increase/decrease even if we disable the input form.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 19 22:34:10 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=64786


Kentaro Hara <haraken at google.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #101302|1                           |0
        is obsolete|                            |




--- Comment #13 from Kentaro Hara <haraken at google.com>  2011-07-19 22:34:10 PST ---
(From update of attachment 101302)
View in context: https://bugs.webkit.org/attachment.cgi?id=101302&action=review

>> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:60
>> +        }, 600);
> 
> Why do we wait for 600msec? 
> I'm afraid this test will be a very slow test.

The time from when the spin button is clicked till when the repeating starts is defined as initialAutoscrollTimerDelay(), and the velocity of the repeating is defined as autoscrollTimerDelay(). These values differ depending on platforms, and in Linux Chromium, initialAutoscrollTimerDelay is 250ms and autoscrollTimerDelay is 50ms. So, at least, 250ms + 50ms = 300ms is needed to fire the first repeating. I changed the 600ms to 500ms.

>> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:65
>> +    input.readOnly = "readonly";
> 
> The type of HTMLInputElement::readOnly is boolean, not string.

Done.

>> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:72
>> +    input.disabled = "disabled";
> 
> The type of HTMLInputElement::disabled is boolean, not string.

Done.

>> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:81
>> +    input.readOnly = undefined;
> 
> ditto.

Done.

>> Source/WebCore/ChangeLog:25
>> +        (WebCore::HTMLElement::releaseCapture): A virtual method.
> 
> "A virtual method." isn't helpful.
> We should write what is changed, reasons of the change, or a purpose of the function.

Done.

>> Source/WebCore/ChangeLog:31
>> +        (WebCore::InputType::readonlyAttributeChanged): A virtual method.
> 
> ditto.

Done.

>> Source/WebCore/html/HTMLElement.h:87
>> +
> 
> I don't think we need to add this function to HTMLElement.
> TextFieldInputType can know m_innerSpinButton type is SpinButtonElement.

Removed it.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list