[Webkit-unassigned] [Bug 51897] Escape should clear search field
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Jul 14 22:44:09 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=51897
Kent Tamura <tkent at chromium.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #100927|review? |review-
Flag| |
--- Comment #18 from Kent Tamura <tkent at chromium.org> 2011-07-14 22:44:08 PST ---
(From update of attachment 100927)
View in context: https://bugs.webkit.org/attachment.cgi?id=100927&action=review
r- because of patch conflicts.
> LayoutTests/fast/forms/input-search-press-escape-key.html:65
> +}
> +
Please show a manual test instruction if there is no layoutTestController or eventSender.
> Source/WebCore/html/SearchInputType.cpp:107
> + if (input->disabled() || input->readOnly())
> + return;
TextFieldInputType::handleKeydownEvent() should be called even if the input is not editable.
It doesn't affect any behavior. It's for consistency.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list