[Webkit-unassigned] [Bug 62840] Optimize HTMLInputElement::updateCheckedRadioButtons

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 11 05:39:29 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62840


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #100267|review?                     |review-
               Flag|                            |




--- Comment #8 from Kent Tamura <tkent at chromium.org>  2011-07-11 05:39:29 PST ---
(From update of attachment 100267)
View in context: https://bugs.webkit.org/attachment.cgi?id=100267&action=review

> Source/WebCore/ChangeLog:3
> +        Fix the bug Optimize HTMLInputElement::updateCheckedRadioButtons

nit:
The summary looks a little curious.
"Optimize HTMLInputELement::updateCheckedRadioButton()" is enough.

> Source/WebCore/ChangeLog:14
> +        (WebCore::Document::getFormElements):
> +        * html/HTMLInputElement.cpp:
> +        (WebCore::HTMLInputElement::updateCheckedRadioButtons):
> +        (WebCore::HTMLInputElement::setChecked):

nit:
We had better explanations about what is changed in each of functions.

> Source/WebCore/html/HTMLInputElement.cpp:890
> +    if (type() != (InputTypeNames::checkbox())) {

if (isRadioButton())
would be natural.

> Source/WebCore/html/HTMLInputElement.cpp:892
> +        setNeedsValidityCheck();

setNeedsValidaityCheck() should be called in a case of checkbox.
EWS failure of fast/forms/interactive-validation-required-checkbox.html was caused by this change.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list