[Webkit-unassigned] [Bug 48781] Add a resourceload delegate method to query if WebCore should paint the default broken image for failed images.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Jan 3 14:18:29 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=48781
Darin Adler <darin at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #77846|review? |review+
Flag| |
--- Comment #14 from Darin Adler <darin at apple.com> 2011-01-03 14:18:28 PST ---
(From update of attachment 77846)
View in context: https://bugs.webkit.org/attachment.cgi?id=77846&action=review
> Tools/DumpRenderTree/mac/ResourceLoadDelegate.mm:245
> +- (BOOL)webView: (WebView*)wv shouldPaintBrokenImage:(NSURL*)imageURL
Extras space here. Also, I would use a longer variable name rather than "wv".
> WebKit/mac/WebView/WebResourceLoadDelegatePrivate.h:63
> +/*!
> + @method webView:shouldPaintBrokenImage:(NSURL*)imageURL
> + @abstract This message is sent when an image cannot be decoded or displayed.
> + @param imageURL The url of the offending image.
> + @result return YES if WebKit should paint the default broken image.
> + */
> +- (BOOL)webView:(WebView*)sender shouldPaintBrokenImage:(NSURL*)imageURL;
> @end
I would think this should be named shouldPaintBrokenImageForURL: given the usual Objective-C naming scheme. In non-ObjC code, there is no need to include the argument name in the function name, but in ObjC method names we normally do.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list