[Webkit-unassigned] [Bug 51818] GeolocationPositionCache should not use ScriptExecutionContext::Task
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Jan 3 11:30:58 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=51818
Darin Adler <darin at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #77826|review? |review+
Flag| |
--- Comment #3 from Darin Adler <darin at apple.com> 2011-01-03 11:30:59 PST ---
(From update of attachment 77826)
View in context: https://bugs.webkit.org/attachment.cgi?id=77826&action=review
It seems a little strange to make a function object and name it Task. But OK.
> Source/JavaScriptCore/wtf/Task.h:40
> + virtual ~Task() {}
We put spaces between braces in cases like that.
> WebCore/fileapi/FileThread.h:58
> - class Task : public Noncopyable {
> + class FileTask : public Task {
Does this really need to be renamed? You could just say this:
class Task : public WTF::Task
That would make the patch smaller, but I guess could be a bit confusing. With the name FileTask it seems it could be made a non-member.
> WebCore/page/GeolocationPositionCache.cpp:48
> + CacheTask(GeolocationPositionCache* cache) : m_cache(cache) {}
We put spaces in those {}
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list