[Webkit-unassigned] [Bug 54786] Devirtualize JSCell::classInfo()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 18 18:28:35 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=54786


WebKit Review Bot <webkit.review.bot at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |webkit.review.bot at gmail.com




--- Comment #3 from WebKit Review Bot <webkit.review.bot at gmail.com>  2011-02-18 18:28:35 PST ---
Attachment 83045 did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/API/JSCallbackConstr..." exit_code: 1

Source/WebCore/bridge/c/CRuntimeObject.cpp:32:  Alphabetical sorting problem.  [build/include_order] [4]
Source/JavaScriptCore/runtime/Structure.h:149:  The parameter name "classInfo" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/runtime/Structure.h:150:  The parameter name "structure" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/bridge/jni/jsc/JavaRuntimeObject.cpp:28:  Found other header before a header this file implements. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Source/WebCore/bridge/jni/jsc/JavaRuntimeObject.cpp:29:  Alphabetical sorting problem.  [build/include_order] [4]
Source/JavaScriptCore/API/JSObjectRef.cpp:343:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
Source/JavaScriptCore/API/JSObjectRef.cpp:355:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
Source/JavaScriptCore/runtime/JSObject.h:325:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/JavaScriptCore/runtime/JSByteArray.cpp:55:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/bridge/jsc/BridgeJSC.cpp:34:  Alphabetical sorting problem.  [build/include_order] [4]
Source/JavaScriptCore/runtime/JSByteArray.h:71:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/API/JSValueRef.cpp:132:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
Total errors found: 12 in 144 files


If any of these errors are false positives, please file a bug against check-webkit-style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list