[Webkit-unassigned] [Bug 54580] [chromium] Enable media elements statistics support in chromium
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Feb 17 23:41:39 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=54580
Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #82828|review?, commit-queue? |review-
Flag| |
--- Comment #7 from Darin Fisher (:fishd, Google) <fishd at chromium.org> 2011-02-17 23:41:38 PST ---
(From update of attachment 82828)
View in context: https://bugs.webkit.org/attachment.cgi?id=82828&action=review
> Source/WebKit/chromium/public/WebMediaPlayer.h:132
> + virtual unsigned long decodedFrames() const = 0;
nit: webkit style is to just use "unsigned" instead of "unsigned long"
nit: are "decodedFrames" and "droppedFrames" meant to return counts of {decoded,dropped}Frames?
if so, the names of these methods could be improved. as is, it sounds like the methods should
be returning sets of frames--one set of decoded frames and one set of dropped frames, but clearly
that's not what they do since they return integers.
How about one of these names?
{count,number}Of{Decoded,Dropped}Frames
{decoded,dropped}FrameCount
> Source/WebKit/chromium/src/WebMediaPlayerClientImpl.cpp:453
> +unsigned long WebMediaPlayerClientImpl::decodedFrames() const
looks like the WebCore interfaces have the same naming problem.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list