[Webkit-unassigned] [Bug 73366] [Qt] Last mouse event could be lost if a JS call to eventSender.leapForward is made

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 1 05:46:09 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=73366





--- Comment #7 from Hugo Parente Lima <hugo.lima at openbossa.org>  2011-12-01 05:46:09 PST ---
(From update of attachment 117279)
View in context: https://bugs.webkit.org/attachment.cgi?id=117279&action=review

Thanks for the review Kenny, I'll make the changes and re-submit the patch.

>> Tools/WebKitTestRunner/qt/EventSenderProxyQt.cpp:53
>> +static bool replayingEvents;
> 
> isReplayingEvents would be a slightly better name (and more inline with WebKit)

Agree.

>> Tools/WebKitTestRunner/qt/EventSenderProxyQt.cpp:417
>> +    int startOfQueue = 0;
> 
> When you are iterating on this, I am not sure the name is that good.

I'm iterating on this and moving the start of the queue, depends on the point of view =], ok to rename it to "i" ?

>> Tools/WebKitTestRunner/qt/EventSenderProxyQt.cpp:425
>> +        delete ev.m_event;
> 
> So we had a memory leak before? Add some more info to the changelog?

We hadn't, the previous implementation used postEvent instead of sendEvent, but using postEvent could cause last event to never be delivered if the widget was already deleted while the event was waiting on Qt event queue.

>> LayoutTests/ChangeLog:12

> 
> dont-loose! not lost

Yes sir!

>> LayoutTests/ChangeLog:13
>> +        * fast/events/dont-lost-last-event.html: Added.
> 
> Having it in event doesn't make that much sense as it is a test of the testing tool instead of a test of webkit events. I wonder where it should be put.

I new here, so a suggestion is appreciated :-)

>> LayoutTests/fast/events/dont-lost-last-event.html:54
>> +        <div id="targetElem" style="border: 1px dashed" onMouseOver="pass()">Pass the mouse over me.<br/><br/></div>
> 
> we normally just write "onmouseover"

Ok, this was my camel case syndrome.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list