[Webkit-unassigned] [Bug 73366] [Qt] Last mouse event could be lost if a JS call to eventSender.leapForward is made

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 1 02:14:26 PST 2011


--- Comment #6 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2011-12-01 02:14:26 PST ---
(From update of attachment 117279)
View in context: https://bugs.webkit.org/attachment.cgi?id=117279&action=review

> Tools/WebKitTestRunner/qt/EventSenderProxyQt.cpp:53
> +static bool replayingEvents;

isReplayingEvents would be a slightly better name (and more inline with WebKit)

> Tools/WebKitTestRunner/qt/EventSenderProxyQt.cpp:417
> +    int startOfQueue = 0;

When you are iterating on this, I am not sure the name is that good.

> Tools/WebKitTestRunner/qt/EventSenderProxyQt.cpp:425
> +        delete ev.m_event;

So we had a memory leak before? Add some more info to the changelog?

> LayoutTests/ChangeLog:12
> +        * fast/events/dont-lost-last-event-expected.txt: Added.

dont-loose! not lost

> LayoutTests/ChangeLog:13
> +        * fast/events/dont-lost-last-event.html: Added.

Having it in event doesn't make that much sense as it is a test of the testing tool instead of a test of webkit events. I wonder where it should be put.

> LayoutTests/fast/events/dont-lost-last-event.html:54
> +        <div id="targetElem" style="border: 1px dashed" onMouseOver="pass()">Pass the mouse over me.<br/><br/></div>

we normally just write "onmouseover"

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list