[Webkit-unassigned] [Bug 48483] Get rid of ResourceRequestBase::m_targetType

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 2 12:46:03 PDT 2011


--- Comment #13 from jochen at chromium.org  2011-08-02 12:46:03 PST ---
(In reply to comment #12)
> One way to solve this problem is to add a parameter to FrameLoaderClient::willSendRequest that is like the current TargetType enumeration.  (Maybe it needs a better name.)
> Chromium needs a way to know the intended purpose of a ResourceRequest that WebCore is making.  This is for all the reasons listed in comment #10.  It seems like passing that information up to the FrameLoaderClient is the correct way to address a use case like this.
> Chromium can then store that information for later use.  This would allow us to remove ResourceRequest{Base}::TargetType completely.

How would you get that information from the point of where the ResourceRequest is created to FrameLoaderClient::willSendRequest. Add it to the options used to create the loader?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list