[Webkit-unassigned] [Bug 58259] Web Inspector: Enable raw HTTP headers support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 13 09:00:31 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=58259





--- Comment #8 from Vsevolod Vlasov <vsevik at chromium.org>  2011-04-13 09:00:30 PST ---
(From update of attachment 89258)
View in context: https://bugs.webkit.org/attachment.cgi?id=89258&action=review

>> Source/WebCore/inspector/Inspector.json:344
>> +                    "timing": { "$ref": "ResourceTiming", "optional": true, "description": "Timing information for the given request." },
> 
> you will need to merge this.

Merged.

>> Source/WebCore/inspector/Inspector.json:345
>> +                    "rawHeaders": { "type": "string", "optional": true, "description": "Raw HTTP response headers." },
> 
> rawHeadersText ?
> rawRequestHeadersText ?

Done.

>> Source/WebCore/inspector/front-end/Resource.js:425
>> +        if (typeof(this._requestHeadersSize) === 'undefined') {
> 
> Please use double quotes.

Done.

>> Source/WebCore/inspector/front-end/ResourceHeadersView.js:219

> 
> Could you pass boolean flag instead of passing the function?

Removed this logic from _refreshHeaders/_refreshRawHeaders functions.

>> Source/WebKit/chromium/src/WebHTTPLoadInfo.cpp:120
>> +    m_private->rawRequestHeaders = rawHeaders;
> 
> Headers above are not less raw, should you rename this to setRawRequestHeadersText?

Added text everywhere.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list