[Webkit-unassigned] [Bug 58259] Web Inspector: Enable raw HTTP headers support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 13 04:28:11 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=58259


Pavel Feldman <pfeldman at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #89258|review?                     |review-
               Flag|                            |




--- Comment #7 from Pavel Feldman <pfeldman at chromium.org>  2011-04-13 04:28:10 PST ---
(From update of attachment 89258)
View in context: https://bugs.webkit.org/attachment.cgi?id=89258&action=review

> Source/WebCore/inspector/Inspector.json:344
> +                    "timing": { "$ref": "ResourceTiming", "optional": true, "description": "Timing information for the given request." },

you will need to merge this.

> Source/WebCore/inspector/Inspector.json:345
> +                    "rawHeaders": { "type": "string", "optional": true, "description": "Raw HTTP response headers." },

rawHeadersText ?
rawRequestHeadersText ?

> Source/WebCore/inspector/front-end/Resource.js:425
> +        if (typeof(this._requestHeadersSize) === 'undefined') {

Please use double quotes.

> Source/WebCore/inspector/front-end/ResourceHeadersView.js:219
> +            this._refreshHeaders(WebInspector.UIString("Request Headers"), this._resource.sortedRequestHeaders, additionalRow, this._requestHeadersTreeElement, rawHeadersToggleFunction);

Could you pass boolean flag instead of passing the function?

> Source/WebCore/inspector/front-end/ResourceHeadersView.js:282
> +    _refreshHeaders: function(title, headers, additionalRow, headersTreeElement, rawHeadersToggleFunction)

usually we don't pass functions other than callbacks. What is it needed for?

> Source/WebKit/chromium/src/WebHTTPLoadInfo.cpp:120
> +    m_private->rawRequestHeaders = rawHeaders;

Headers above are not less raw, should you rename this to setRawRequestHeadersText?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list