[Webkit-unassigned] [Bug 58024] [GTK] Implement page loader client in MiniBrowser

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 13 08:11:55 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=58024





--- Comment #3 from Carlos Garcia Campos <cgarcia at igalia.com>  2011-04-13 08:11:55 PST ---
(In reply to comment #2)
> (From update of attachment 88602 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=88602&action=review
> 
> Nice.
> 
> > Tools/MiniBrowser/gtk/BrowserWindow.c:372
> > +    WKPageLoaderClient loadClient = {
> > +        0,       /* version */
> > +        window, /* clientInfo */
> > +        didStartProvisionalLoadForFrame,
> > +        didReceiveServerRedirectForProvisionalLoadForFrame,
> > +        didFailProvisionalLoadWithErrorForFrame,
> > +        didCommitLoadForFrame,
> > +        didFinishDocumentLoadForFrame,
> > +        didFinishLoadForFrame,
> > +        didFailLoadWithErrorForFrame,
> > +        0, /* didSameDocumentNavigationForFrame */
> > +        didReceiveTitleForFrame,
> > +        didFirstLayoutForFrame,
> > +        didFirstVisuallyNonEmptyLayoutForFrame,
> > +        didRemoveFrameFromHierarchy,
> > +        0, /* didDisplayInsecureContentForFrame */
> > +        0, /* didRunInsecureContentForFrame */
> > +        0, /* canAuthenticateAgainstProtectionSpaceInFrame */
> > +        0, /* didReceiveAuthenticationChallengeInFrame */
> > +        didStartProgress,
> > +        didChangeProgress,
> > +        didFinishProgress,
> > +        didBecomeUnresponsive,
> > +        didBecomeResponsive,
> > +        0,  /* processDidCrash */
> > +        0,  /* didChangeBackForwardList */
> > +        0   /* shouldGoToBackForwardListItem */
> > +    };
> > +    WKPageSetPageLoaderClient(WKViewGetPage(window->webView), &loadClient);
> 
> Do you mind lining up the comments on these lines?

Sure.

> > Tools/MiniBrowser/gtk/BrowserWindow.c:376
> > +GtkWidget* browserWindowNew(WKViewRef view)
> 
> Minor bikeshed. Since BrowserWindow is a GObject, I think the public methods should have g_object_naming_style.

Well, this is not exactly public API, it's private to minibrowser, but anyway, I prefer gnome style so I'll happily change it. 

Note that this patch depends on patch attached to bug #57944.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list