[Webkit-unassigned] [Bug 58024] [GTK] Implement page loader client in MiniBrowser

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 13 08:04:51 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=58024


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #88602|review?                     |review+
               Flag|                            |




--- Comment #2 from Martin Robinson <mrobinson at webkit.org>  2011-04-13 08:04:51 PST ---
(From update of attachment 88602)
View in context: https://bugs.webkit.org/attachment.cgi?id=88602&action=review

Nice.

> Tools/MiniBrowser/gtk/BrowserWindow.c:372
> +    WKPageLoaderClient loadClient = {
> +        0,       /* version */
> +        window, /* clientInfo */
> +        didStartProvisionalLoadForFrame,
> +        didReceiveServerRedirectForProvisionalLoadForFrame,
> +        didFailProvisionalLoadWithErrorForFrame,
> +        didCommitLoadForFrame,
> +        didFinishDocumentLoadForFrame,
> +        didFinishLoadForFrame,
> +        didFailLoadWithErrorForFrame,
> +        0, /* didSameDocumentNavigationForFrame */
> +        didReceiveTitleForFrame,
> +        didFirstLayoutForFrame,
> +        didFirstVisuallyNonEmptyLayoutForFrame,
> +        didRemoveFrameFromHierarchy,
> +        0, /* didDisplayInsecureContentForFrame */
> +        0, /* didRunInsecureContentForFrame */
> +        0, /* canAuthenticateAgainstProtectionSpaceInFrame */
> +        0, /* didReceiveAuthenticationChallengeInFrame */
> +        didStartProgress,
> +        didChangeProgress,
> +        didFinishProgress,
> +        didBecomeUnresponsive,
> +        didBecomeResponsive,
> +        0,  /* processDidCrash */
> +        0,  /* didChangeBackForwardList */
> +        0   /* shouldGoToBackForwardListItem */
> +    };
> +    WKPageSetPageLoaderClient(WKViewGetPage(window->webView), &loadClient);

Do you mind lining up the comments on these lines?

> Tools/MiniBrowser/gtk/BrowserWindow.c:376
> +GtkWidget* browserWindowNew(WKViewRef view)

Minor bikeshed. Since BrowserWindow is a GObject, I think the public methods should have g_object_naming_style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list