[Webkit-unassigned] [Bug 45381] [Gtk] Adjust atk_text_get_text_at_offset to account for bullets/numbers in list items

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 22 03:54:19 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45381





--- Comment #5 from Mario Sanchez Prada <msanchez at igalia.com>  2010-09-22 03:54:19 PST ---
(In reply to comment #4)
> (From update of attachment 67808 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=67808&action=review
> 
> i don't know how other people feel about adding a variable to RenderListMarker. sometimes they are quite picky about that. 

Well, that's the best way I found to allow returning the marker's suffix without having to recalculate it each time. But if there's a better way to do it, I'm more than happy to change it.

> need a layout test for this however

Wouldn't it be enough with an unit test to check the marker is what it's supposed to be?

> > WebCore/ChangeLog:39
> > +
> 
> indent comments when they are underneath the a filename. it makes it easier to read

Ok

> > WebCore/accessibility/gtk/AccessibilityObjectWrapperAtk.cpp:1218
> > +    RenderObject* renderer = static_cast<const AccessibilityRenderObject*>(object)->renderer();
> 
> check if renderer is nil as well

Ok.

> > WebCore/rendering/RenderListItem.cpp:325
> > +    const String& markerTxt = m_marker->text();
> 
> var name should be markerText

Ok.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list