[Webkit-unassigned] [Bug 45381] [Gtk] Adjust atk_text_get_text_at_offset to account for bullets/numbers in list items

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 21 14:33:22 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45381


chris fleizach <cfleizach at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #67808|review?                     |review-
               Flag|                            |




--- Comment #4 from chris fleizach <cfleizach at apple.com>  2010-09-21 14:33:22 PST ---
(From update of attachment 67808)
View in context: https://bugs.webkit.org/attachment.cgi?id=67808&action=review

i don't know how other people feel about adding a variable to RenderListMarker. sometimes they are quite picky about that. 

need a layout test for this however

> WebCore/ChangeLog:39
> +

indent comments when they are underneath the a filename. it makes it easier to read

> WebCore/accessibility/gtk/AccessibilityObjectWrapperAtk.cpp:1218
> +    RenderObject* renderer = static_cast<const AccessibilityRenderObject*>(object)->renderer();

check if renderer is nil as well

> WebCore/rendering/RenderListItem.cpp:325
> +    const String& markerTxt = m_marker->text();

var name should be markerText

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list