[Webkit-unassigned] [Bug 45288] Fix speech button's hit test logic for RTL rendering.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Sep 7 05:43:05 PDT 2010
https://bugs.webkit.org/show_bug.cgi?id=45288
--- Comment #3 from Satish Sampath <satish at chromium.org> 2010-09-07 05:43:05 PST ---
(In reply to comment #2)
> > <script src="../js/resources/js-test-post.js"></script>
> Is there any precedent for this - writing the test as a non-script-test, but using the script-test resources?
These includes are not script-test related but general JS test helpers, used by most tests. For e.g. an indexed db test - http://trac.webkit.org/browser/trunk/LayoutTests/storage/indexeddb/objectstore-cursor.html
> > diff --git a/WebCore/rendering/RenderTextControlSingleLine.cpp b/WebCore/rendering/RenderTextControlSingleLine.cpp
> > + FloatPoint localPoint = absoluteToLocal(static_cast<MouseEvent*>(event)->absoluteLocation(), false, true);
> I know that this variable is scoped to not conflict with localPoint below, but using a different name would help with readability.
Will do.
>
> > + if (speechBox->frameRect().contains(static_cast<int>(localPoint.x()), static_cast<int>(localPoint.y()))) {
> Why are the static casts required?
.x() and .y() return floats, and I explicitly casted them to int to avoid compile warnings/errors of precision loss.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list