[Webkit-unassigned] [Bug 45288] Fix speech button's hit test logic for RTL rendering.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 7 04:53:29 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45288





--- Comment #2 from Steve Block <steveblock at google.com>  2010-09-07 04:53:30 PST ---
(From update of attachment 66704)
> diff --git a/LayoutTests/fast/speech/input-text-speechbutton.html b/LayoutTests/fast/speech/input-text-speechbutton.html
>  <script src="../js/resources/js-test-post.js"></script>
Is there any precedent for this - writing the test as a non-script-test, but using the script-test resources?

> diff --git a/WebCore/rendering/RenderTextControlSingleLine.cpp b/WebCore/rendering/RenderTextControlSingleLine.cpp
> +        FloatPoint localPoint = absoluteToLocal(static_cast<MouseEvent*>(event)->absoluteLocation(), false, true);
I know that this variable is scoped to not conflict with localPoint below, but using a different name would help with readability.

> +        if (speechBox->frameRect().contains(static_cast<int>(localPoint.x()), static_cast<int>(localPoint.y()))) {
Why are the static casts required?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list