[Webkit-unassigned] [Bug 45443] [GTK] Support for viewport meta tag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 29 13:33:02 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45443


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #72287|review?                     |review-
               Flag|                            |




--- Comment #49 from Martin Robinson <mrobinson at webkit.org>  2010-10-29 13:33:00 PST ---
(From update of attachment 72287)
View in context: https://bugs.webkit.org/attachment.cgi?id=72287&action=review

> WebKit/gtk/webkit/webkitprivate.h:326
> +    void
> +    webkit_viewport_attributes_set(WebKitViewportAttributes* viewportAttributes, const WebCore::ViewportAttributes& attrs, gboolean userScalable);

This may be uneeded. See below.

> WebKitTools/DumpRenderTree/LayoutTestController.h:287
> +    void configurationForViewport(int availableWidth, int availableHeight);

This method actually dumps the viewport so it should be called dumpConfigurationForViewport.

> WebKitTools/DumpRenderTree/gtk/LayoutTestControllerGtk.cpp:836
> +    DumpRenderTreeSupportGtk::updateViewportAttributes(webView, availableWidth, availableHeight);

I'm a little worried because the Qt implementation doesn't actually set the viewport attributes on the view. Seemingly it just calculates the appropriate viewport given the size. Shouldn't we try to replicate that as closely as possible?

Perhaps this should just call a method like this:

WebKitViewportAttributes* attributes = DumpRenderTreeSupportGtk::computeViewportAttributesForSize(availbleWidth, availableHeight);

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list