[Webkit-unassigned] [Bug 45443] [GTK] Support for viewport meta tag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 29 18:15:38 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45443





--- Comment #50 from Joone Hur <joone at kldp.org>  2010-10-29 18:15:37 PST ---
(In reply to comment #49)
> (From update of attachment 72287 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=72287&action=review
> 
> > WebKit/gtk/webkit/webkitprivate.h:326
> > +    void
> > +    webkit_viewport_attributes_set(WebKitViewportAttributes* viewportAttributes, const WebCore::ViewportAttributes& attrs, gboolean userScalable);
> 
> This may be uneeded. See below.

If we don't need it, we should use the setters or GObject property methods.

> 
> > WebKitTools/DumpRenderTree/LayoutTestController.h:287
> > +    void configurationForViewport(int availableWidth, int availableHeight);
> 
> This method actually dumps the viewport so it should be called dumpConfigurationForViewport.
> 
> > WebKitTools/DumpRenderTree/gtk/LayoutTestControllerGtk.cpp:836
> > +    DumpRenderTreeSupportGtk::updateViewportAttributes(webView, availableWidth, availableHeight);
> 
> I'm a little worried because the Qt implementation doesn't actually set the viewport attributes on the view. Seemingly it just calculates the appropriate viewport given the size. Shouldn't we try to replicate that as closely as possible?

Do we need to create a new WebKitViewportAttributes object whenever the browser loads the viewport meta tags or the device screen changes? If so, it seems a bit overhead, but I will try it.

> Perhaps this should just call a method like this:
> 
> WebKitViewportAttributes* attributes = DumpRenderTreeSupportGtk::computeViewportAttributesForSize(availbleWidth, availableHeight);

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list