[Webkit-unassigned] [Bug 47384] ARMv7 JIT should generated conditional branches when possible

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 13 11:23:41 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47384





--- Comment #10 from Geoffrey Garen <ggaren at apple.com>  2010-10-13 11:23:41 PST ---
Here's an alternative:

1. JumpConditionFixedSize, JumpNoConditionFixedSize. "Fixed size" is a little more specific and modular, since you don't have to know that the patching machinery relies on fixed sized instructions in order to know what "fixed size" means. Using a suffix helps communicate that these are just like the other similarly named jumps, with the modifier of having a fixed size.

I think it would also be helpful to readability to add a "canCompact(JumpType)" helper function. That way, branch compacting code can just do this:

if (!canCompact(jumpType))
    // bail out

And if we add / remove jump types, we only need to modify the central helper function, not each of these clients. We can also place the comment explaining which jump types can't compact in one place.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list