[Webkit-unassigned] [Bug 47384] ARMv7 JIT should generated conditional branches when possible

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 13 13:16:09 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47384


Oliver Hunt <oliver at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |NEW
     Ever Confirmed|0                           |1




--- Comment #11 from Oliver Hunt <oliver at apple.com>  2010-10-13 13:16:09 PST ---
(In reply to comment #10)
> Here's an alternative:
> 
> 1. JumpConditionFixedSize, JumpNoConditionFixedSize. "Fixed size" is a little more specific and modular, since you don't have to know that the patching machinery relies on fixed sized instructions in order to know what "fixed size" means. Using a suffix helps communicate that these are just like the other similarly named jumps, with the modifier of having a fixed size.
> 
> I think it would also be helpful to readability to add a "canCompact(JumpType)" helper function. That way, branch compacting code can just do this:
> 
> if (!canCompact(jumpType))
>     // bail out
> 
> And if we add / remove jump types, we only need to modify the central helper function, not each of these clients. We can also place the comment explaining which jump types can't compact in one place.

These seem like good names, and canCompact is a good addition.  My primary issue with the Patchable prefixes were that I felt you could reasonably interpret "Patchable" as meaning the linker was able to patch the link into another form.

David you may find it helpful to run the style checker before you upload, it's in the normal checkout at:
WebKitTools/Scripts/check-webkit-style

There's also the webkit-patch script that can automate the process of submitting a patch if you're interested.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list