[Webkit-unassigned] [Bug 39908] Reentrant Geolocation tests crash with an assertion

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 18 06:55:44 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=39908


Marcus Bulach <bulach at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bulach at chromium.org




--- Comment #11 from Marcus Bulach <bulach at chromium.org>  2010-11-18 06:55:43 PST ---
(In reply to comment #10)
> (From update of attachment 74119 [details])
> LGTM. I'd be inclined to comment why we ignore watchersCached, or at least name it ignoreWatchersCached, or maybe even pass a NULL pointer into removeCachedNotifiers to avoid copying out the unneeded refs. I don't know which fits best with webkit style though?

some comments:
View in context: https://bugs.webkit.org/attachment.cgi?id=74119&action=review

> WebCore/page/Geolocation.cpp:525
> +void Geolocation::removeCachedNotifiers(GeoNotifierVector& notifiers, GeoNotifierVector& cached)

hmm, I was a bit confused with this name and the fact that it has two params, my original thought was that it was removing "cached" from "notifiers"..
not sure if it'd be any clearer, but perhaps extractNotifiersWithCachedPosition?

also, both this and copyToSet could be static helper functions rather than regular methods.

> WebCore/page/Geolocation.cpp:561
> +    GeoNotifierVector oneShotsCached;

as above, perhaps oneShotsWithCachedPosition

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list