[Webkit-unassigned] [Bug 39854] Refactor platform dependent editing behavior code out of Settings

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 28 08:51:27 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39854





--- Comment #6 from Darin Adler <darin at apple.com>  2010-05-28 08:51:22 PST ---
(In reply to comment #5)
> In this design, for each specific editing behavior there would be a method in Settings and a correspondent method in EditingBehaviorController. The former returns a forward the call of the latter.

General idea looks good, but I think this is something to be avoided. We don't want to have to add two functions every time we add a new editing behavior.

I suggest making the "controller" class public, and in fact the class itself could be in a separate header file and not be a member of settings. There should be a getter on the Settings class that returns it with a short name. Then you can say:

    settings->editing().shouldMoveCaretToBoundary()

The only part I'm not sure of is what the optimal name for EditingBehaviorController and Settings::editing() are. I think the object represents editing behavior details, interpretation, or policy. Controller might be an OK term too. For the Settings member, the key is brevity.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list