[Webkit-unassigned] [Bug 38749] [Chromium] Pipe RTL info into WebPopupMenuInfo

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 7 10:09:55 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38749





--- Comment #4 from David Levin <levin at chromium.org>  2010-05-07 10:09:55 PST ---
(From update of attachment 55374)
Since this has a change to a public api file, I'll leave it for Darin Fisher to
give a r+/r-, but here's a comment on a minor WebKit style issue that it would
be good to fix.

> Index: WebCore/page/chromium/ChromeClientChromium.h
>      virtual void popupOpened(PopupContainer* popupContainer, const IntRect& bounds,
> +                             bool handleExternal, PopupMenuClient* popupClient) = 0;

Style nit: Since the parameter name "popupClient" provide no new information,
it shouldn't be here.
(The same is true for popupContainer but that itsn't part of your change.)


> Index: WebKit/chromium/src/ChromeClientImpl.h
>      virtual void popupOpened(WebCore::PopupContainer* popupContainer,
>                               const WebCore::IntRect& bounds,
> +                             bool handleExternally,
> +                             WebCore::PopupMenuClient* popupClient);

Ditto.

> +    void getPopupMenuInfo(WebCore::PopupContainer*, WebPopupMenuInfo*, WebCore::PopupMenuClient* popupClient);

Ditto.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list