[Webkit-unassigned] [Bug 36395] [Qt] Patch to add support for Content-Disposition...

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 29 19:44:55 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=36395





--- Comment #40 from adawit at kde.org  2010-03-29 19:44:55 PST ---
(In reply to comment #39)
> I emailed webkit-dev the following:
> 
> Since two platforms now share this same code in their WebKit layers, it seems
> okay that this was moved into some shared location.  But I have a few gripes:
> 
> HTTPParsers is about parsing HTTP, not implementing policy.  A better place is
> probably ResourceResponse itself.
>
> But as written the method implements a client policy.  This reeks of breaking
> the layering between WebCore and WebKit.  I would feel a lot better about it if
> the method was:
> String ResourceResponseBase::contentDispositionType() const;

Though I have no particular objection to where this functionality ends up, I do
not see how determining the type of content disposition is any different from
determining the filename from the content-disposition header. In fact the
filename portion of this header might be completely useless depending on the
type attribute (inline or attachment or nothing). And since the code that
determines the filename 

String filenameFromHTTPContentDisposition(const String&);

already exists in this very same file, would it not make sense to have the
other one here too ? Perhaps changing how it is implemented would ease the
gripes you have with it ? How about changing it to

bool HTTPParsers::isAttachmentContentDisposition(const String&) ; 

OR

enum ContentDispositionType
{
     Inline,
     Attachment
};

int HTTPParsers::contentDispositionType(const String&);

instead ?

Regards,
Dawit A.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list