[Webkit-unassigned] [Bug 36259] <input type=range> does not validate correctly without a renderer and the tests are incorrect

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 18 19:00:47 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=36259


David Kilzer (ddkilzer) <ddkilzer at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #51118|review?                     |review+
               Flag|                            |




--- Comment #19 from David Kilzer (ddkilzer) <ddkilzer at webkit.org>  2010-03-18 19:00:46 PST ---
(From update of attachment 51118)
> diff --git a/WebCore/html/HTMLInputElement.cpp b/WebCore/html/HTMLInputElement.cpp

Nit:  Update copyright.

> +    case RANGE: // Guarenteed by sanitization.
> +        ASSERT(parseToDouble(value(), nan) <= maximum());

Typo:  Guaranteed

> +    case RANGE: // Guarenteed by sanitization.
> +        ASSERT(parseToDouble(value(), nan) <= maximum());

Typo:  Guaranteed

> diff --git a/WebCore/html/StepRange.cpp b/WebCore/html/StepRange.cpp
> +double StepRange::clampValue(const String& stringValue)
> +{
> +    double oldValue;

I would call this value since "oldValue" implies a "newValue", and we don't
have one of those here.

r=me

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list