[Webkit-unassigned] [Bug 40608] [chromium]Refactor input method related APIs.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 15 10:57:27 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40608





--- Comment #10 from James Su <suzhe at chromium.org>  2010-06-15 10:57:25 PST ---
(In reply to comment #9)
> (From update of attachment 58757 [details])
> WebCore/page/FocusController.cpp:600
>  +      // session.
> FWIW, this sounds like a functional change, even though the ChangeLog says this isn't a functional change.
Or maybe I should say there is no new functionality?

> 
> WebKit/chromium/src/WebViewImpl.h:100
>  +      virtual bool setComposition(
> Should this return more than just a bool?  For example, I think the cancel composition work would be easier if this returned an enum (COMPOSITION_SET, COMPOSITION_CANCELED, or KEYPRESS_CANCELED) or something.  A bool is probably fine if there's a way to query what the current composition text is (e.g., if a keydown is prevented, setComposition can return false and the render view can query the webview to see what the current composition text should be set to in the browser process).
Returning boolean should be enough. This method should only return false when the input method has some composition text but the webkit can't accept it by any reason, then the only thing can be done is to cancel the input method's composition text.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list