[Webkit-unassigned] [Bug 40301] DOM storage should only create databases when needed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 9 03:00:00 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40301


Jeremy Orlow <jorlow at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #58154|review?                     |review-
               Flag|                            |




--- Comment #5 from Jeremy Orlow <jorlow at chromium.org>  2010-06-09 03:00:00 PST ---
(From update of attachment 58154)
WebCore/storage/StorageAreaSync.cpp:66
 +      , m_triedOpeningDatabase(false)
How about m_databaseOpenFailed

WebCore/storage/StorageAreaSync.cpp:206
 +      ASSERT(!m_database.isOpen());
Assert we haven't tried yet.

WebCore/storage/StorageAreaSync.h:79
 +            CreateDatabase,
These names are not very clear.  The point is that creation is allowed, but this sounds like you're saying always create it.

WebCore/storage/StorageAreaSync.cpp:307
 +      if (!m_database.isOpen() && !m_triedOpeningDatabase)
If you change the name as I suggested, then you can simply do "if m_databaseOpenFailed return;" before this statement.  I think it's more clear.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list