[Webkit-unassigned] [Bug 40134] Web Inspector: sendMessageToFrontend implementation required.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 3 15:04:51 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40134


Pavel Feldman <pfeldman at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #57805|review?                     |review-
               Flag|                            |




--- Comment #6 from Pavel Feldman <pfeldman at chromium.org>  2010-06-03 15:04:49 PST ---
(From update of attachment 57805)
WebCore/ChangeLog:5
 +          WebInspector: It should be possible to transfer timeline/dom/etc data from inspected page side to the front-end side in serialized format.
Please wrap it at 80 chars or so.

WebCore/inspector/InspectorController.cpp:429
 +  void InspectorController::connectFrontend(const ScriptObject& webInspector)
I think "attach" would be a better name. Also I would leave a comment saying that webInspector parameter is going to go away once we migrate to the new schema.

WebKit/mac/WebCoreSupport/WebInspectorClient.mm:107
 +      return m_webInspectorFrontendClient->dispatchMessageToFrontend(message);
This one is I think wrong. You are telling client of the inspected page (InspectorClient) to dispatch message on the frontend via the InspectorFrontend's client. But methods on client are to be called by WebCore, not WebKit. You should simply get a pointer to the Page and dispatch the JS call there.

WebCore/WebCore.Inspector.exp:24
 +  __ZN7WebCore28InspectorFrontendClientLocal25dispatchMessageToFrontendERKNS_6StringE
This one should not be visible to WebKit. In fact, this entire InspectorFrontendClientLocal class should go away since it exposes a way too rich WebCore API to the WebKit.

WebKit/qt/WebCoreSupport/InspectorClientQt.cpp:165
 +      return false;
You plan on implementing these prior to landing, right?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list