[Webkit-unassigned] [Bug 41607] DeviceOrientationEvent should use optional properties

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 12 06:17:31 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=41607


Jeremy Orlow <jorlow at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #61208|review?                     |review+
               Flag|                            |




--- Comment #8 from Jeremy Orlow <jorlow at chromium.org>  2010-07-12 06:17:31 PST ---
(From update of attachment 61208)

LayoutTests/fast/dom/DeviceOrientation/script-tests/optional-event-properties.js:39
 +  event.initDeviceOrientationEvent("", false, false, null, null, null);
if you used evalAndLog, then this would be printed to the console too, so it'd be easier to read without much additional effort.

WebCore/dom/DeviceOrientation.h:53
 +      DeviceOrientation()
There's enough code here I'd lean towards putting it in a .cpp file.

WebCore/bindings/js/JSDeviceOrientationEventCustom.cpp:2
 +   * Copyright 2010, The Android Open Source Project
Since these contributions are for sure from Google, should the copyright just read Google?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list