[Webkit-unassigned] [Bug 33418] [Qt] Custom select popups.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 18 05:39:09 PST 2010


--- Comment #27 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2010-01-18 05:39:07 PST ---
(In reply to comment #26)
> Some suggestions that I mentioned this on irc, pasting here for the record.
> 1. Rename populate to setItems
> 2. Rename setIndex to setSelectedIndex or setCurrentIndex?

int    currentIndex () const
void    setCurrentIndex ( int index )

Seems to be the Qt way.

> 3. show() should not ideally have a selectedIndex argument. Have a separate
> select() maybe?

maybe add a geometry() method as well as the currentIndex()! so on show you can
call these yourself.

> 4. didHide to something more Qtish like close() or accept() or setAccepted().
> (I hope I understood it's intention correctly).

It is a method called by webcore. Maybe we should emit something like:

void QGraphicsObject::visibleChanged ()   [signal]
void QDockWidget::visibilityChanged ( bool visible )   [signal]

hmm, Qt has a problem with naming here :-)

> 5. parentWidget() needs a better name, but I don't have a better suggestion.

What about view() ?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list