[Webkit-unassigned] [Bug 33418] [Qt] Custom select popups.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 18 05:03:15 PST 2010


--- Comment #26 from Girish Ramakrishnan <girish at forwardbias.in>  2010-01-18 05:03:12 PST ---
Some suggestions that I mentioned this on irc, pasting here for the record.

1. Rename populate to setItems
2. Rename setIndex to setSelectedIndex or setCurrentIndex?
3. show() should not ideally have a selectedIndex argument. Have a separate
select() maybe?
4. didHide to something more Qtish like close() or accept() or setAccepted().
(I hope I understood it's intention correctly).
5. parentWidget() needs a better name, but I don't have a better suggestion.

Also, how does the patch also deal with multiple selections? (luiz said it
doesn't). So, we just leave that for later?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list