[Webkit-unassigned] [Bug 50758] Defer loading print stylesheets

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 13 10:49:18 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=50758





--- Comment #18 from Antti Koivisto <koivisto at iki.fi>  2010-12-13 10:49:17 PST ---
(In reply to comment #15)

> > WebCore/ChangeLog:11
> > +        - Use this mechanism to load print stylesheets using very low priority so they get loaded after everything else.
> 
> I'm slightly worried that this may increase problem rate when actually printing. It will be more likely that a page will not be printable yet when it looks complete on screen. The user would press Cmd+P, and observe broken layout.

It shouldn't be a significant concern. People don't normally print before the page is visually complete. Parallel loading ensures that small number of hanging resources won't prevent the print sheet from getting loaded.

> Please modify other project files.

Done.

> This change is wrong. PassRefPtr should be used when passing ownership - but MediaQueryEvaluator doesn't take ownership of the MediaList.

Oh ok. Fixed.

> > WebCore/html/HTMLLinkElement.cpp:227
> > +    // FIXME: We shouldn't load unnecessary stylesheets at all.
> 
> Please remove this FIXME. There is no such thing as "unnecessary stylesheet".

Stylesheets that are never used are unnecessary to load. This is major performance concern. I have bug open to fix this too.

> This function doesn't use class members, so it should be static. Also, the name implies matching something in class state, which is misleading. I suggest something like "linkMediaAttributeMatchesRenderingIntent" or linkMediaAttributeIsScreen".

Fixed.

> Will this prevent preloading for screen size and resolution specific stylesheets? How bad is that for embedded devices?

Changed to load by default. This can be optimized later.

> > WebKitTools/ChangeLog:5
> > +        Add setSerializeHTTPLoads function to allow testing resource load order on OS X.
> 
> Please consider also implementing this at least for WebKit2.

Later.

> > WebKitTools/DumpRenderTree/mac/LayoutTestControllerMac.mm:1004
> > +    [WebView _setLoadResourcesSerially:serialize forHost:@"127.0.0.1"];
> 
> What is the use case for passing a host here? We'll want at least localhost, too.

Nothing really. I got rid of it and simplified the code in the process.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list