[Webkit-unassigned] [Bug 34005] Safari pegs CPU and drops tons of frames using HTML5 Vimeo player

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 30 18:49:09 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=34005





--- Comment #53 from Jer Noble <jer.noble at apple.com>  2010-04-30 18:49:09 PST ---
(In reply to comment #52)
> (From update of attachment 54600 [details])
> WebCore/platform/graphics/win/QTMovie.cpp:266
>  +          m_private->m_clients.remove(indexOfClient);
> Is this correct?  Do you really never want to remove the first client?

You're right, that should be a ">="

> WebCore/platform/graphics/win/QTMovie.h:60
>  +  class QTMOVIEWIN_API QTMovie : public RefCounted<QTMovie> {
> It seems like this class should be renamed something like QTMovieView or
> QTMovieGWorld.  If you don't want to rename it in this round, please add a
> comment.

I agree that QTMovieWin isn't the correct name, and that QTMovieGWorld would be
better.  I don't mind doing the re-naming this pass.

> 
> WebCore/platform/graphics/win/QTMovieTask.cpp:46
>  +      static QTMovieTask* s_sharedTask = new QTMovieTask();
> This should use the DEFINE_GLOBAL macro.
> 
> r=me but please consider those
> changes.WebCore/platform/graphics/win/QTMovieWin.h:75
>  +      RefPtr<QTMovie> movie() const;
> We don't ever pass or return RefPtr's.  Please see
> http://webkit.org/coding/RefPtr.html for more on that.

It seems like the convention is to move the default constructor into protected:
and add a static constructor method which returns a PassRefPtr.  Should I do
that as well to QTMovie, QTMovieGWorld, and QTMovieVisualContext?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list