[Webkit-unassigned] [Bug 38220] [chromium] Add API for querying whether a WebWidget is using GPU accelerated compositing

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 30 10:34:44 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38220





--- Comment #3 from Vangelis Kokkevis <vangelis at chromium.org>  2010-04-30 10:34:43 PST ---
(In reply to comment #2)
> (From update of attachment 54458 [details])
> WebKit/chromium/public/WebPopupMenu.h:44
>  +      virtual bool isAcceleratedCompositing() const { return false; }
> You should instead implement this method in WebPopupMenuImpl.{h,cpp} just as
> you have done in WebViewImpl.{h,cpp}.
> 
> WebKit/chromium/public/WebWidget.h:95
>  +      virtual bool isAcceleratedCompositing() const = 0;
> nit: isAcceleratedCompositingEnabled would be a better (more consistent with
> naming conventions) name for this.
> 

I agree that name is kind of ugly although I used it for consistency with
Apple's Windows implementation (WebKit/WebKit/win/WebView.h). The original mac
implementation seems to be using:  "isUsingAcceleratedCompositing()" which is
more accurate as it's not about so much about it being enabled but rather about
being active for the View. So, any objections to switching ours to
isUsingAcceleratedCompositing() too? 

> WebKit/chromium/src/WebViewImpl.cpp:2041
>  +      return m_isAcceleratedCompositing;
> ditto.  this variable would be better named m_isAcceleratedCompositingEnabled
> 
> WebKit/chromium/src/WebViewImpl.h:363
>  +      void setAcceleratedCompositing(bool);
> This one should be named enableAcceleratedCompositing to be consistent with
> naming conventions.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list