[Webkit-unassigned] [Bug 38220] [chromium] Add API for querying whether a WebWidget is using GPU accelerated compositing

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 29 20:41:30 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38220


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #54458|review?                     |review-
               Flag|                            |




--- Comment #2 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-04-29 20:41:29 PST ---
(From update of attachment 54458)
WebKit/chromium/public/WebPopupMenu.h:44
 +      virtual bool isAcceleratedCompositing() const { return false; }
You should instead implement this method in WebPopupMenuImpl.{h,cpp} just as
you have done in WebViewImpl.{h,cpp}.

WebKit/chromium/public/WebWidget.h:95
 +      virtual bool isAcceleratedCompositing() const = 0;
nit: isAcceleratedCompositingEnabled would be a better (more consistent with
naming conventions) name for this.

WebKit/chromium/src/WebViewImpl.cpp:2041
 +      return m_isAcceleratedCompositing;
ditto.  this variable would be better named m_isAcceleratedCompositingEnabled

WebKit/chromium/src/WebViewImpl.h:363
 +      void setAcceleratedCompositing(bool);
This one should be named enableAcceleratedCompositing to be consistent with
naming conventions.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list