[Webkit-unassigned] [Bug 28806] [Qt] Make the WebInspector available as a widget class.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 9 05:23:48 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=28806


Simon Hausmann <hausmann at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #39254|review?                     |review-
               Flag|                            |




--- Comment #6 from Simon Hausmann <hausmann at webkit.org>  2009-09-09 05:23:48 PDT ---
(From update of attachment 39254)
Comments from the API discussion in the office here:

> +    void dock();
> +    void undock();
> +    bool isDocked() const;
[...]
> +    void dockRequested();
> +    void undockRequested();

These functions/signals should disappear from the
public API, as the names don't feel right and we'd like
find a better solution in the future. For now it seems
safer to not expose this aspect of the UI.

> +    QWebInspector* inspector() const;

This function should not be part of the public API, too. It doesn't
add any real convenience, as the developer always has a pointer to the
inspector anyway, as owner.

> +    void inspectElementTriggered();

This signal should be renamed to

    void QWebPage::webInspectorTriggered(const QWebElement&);

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list