[Webkit-unassigned] [Bug 28934] Add <input type=number> validation support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 3 11:19:10 PDT 2009


Peter Kasting <pkasting at google.com> changed:

           What    |Removed                     |Added
                 CC|                            |pkasting at google.com

--- Comment #4 from Peter Kasting <pkasting at google.com>  2009-09-03 11:19:09 PDT ---
I disagree with Eric.  Putting "HTML5" in function names is completely
inappropriate given that this functionality will also be required for HTML 6,
7, ... and in fact HTML is switching to be unversioned (see e.g. "DOCTYPE HTML"
and some of Hixie's comments).  These functions should be called things like
"userInputToDouble" or "inputStringToDouble" or something to indicate that the
difference between them and a generic conversion to double is the fact that the
origin is some kind of user input which needs additional validation or

Also, nitpick: "numeber" -> "number" in at least one place.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list