[Webkit-unassigned] [Bug 23147] Introduce Skia to WebKit
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Jan 7 13:08:46 PST 2009
https://bugs.webkit.org/show_bug.cgi?id=23147
eric at webkit.org changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #26479|review?(sam at webkit.org) |review+
Flag| |
------- Comment #14 from eric at webkit.org 2009-01-07 13:08 PDT -------
(From update of attachment 26479)
We only name arguments when the name adds clarity:
+ static PassRefPtr<BitmapImageSingleFrameSkia> create(
+ const SkBitmap& bitmap);
This one doesn't need a name, per the style guidelines.
I'm surprised there isn't just a m_nativeImage.size() accessor:
+ return IntSize(m_nativeImage.width(), m_nativeImage.height());
Also, there is no reason for these virtual functions to be in the headers.
They should just move to the .cpp file IMO (they're virtual, so won't be
inlined).
+ virtual void draw(GraphicsContext* ctxt, const FloatRect& dstRect,
+ const FloatRect& srcRect, CompositeOperator
compositeOp);
compositeOp and ctxt don't need to be there.
Where's BitmapImageSingleFrameSkia.cpp? :) Looks fine. Needs the above
changes and can be landed. Marking r+ assuming you'll change before landing.
If you're still sans commit-bit, then please post a new patch.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list