[Webkit-unassigned] [Bug 24143] Crash occurs at WebCore::AccessibilityTable::isTableExposableThroughAccessibility() when applying a link in GMail

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 25 13:43:27 PST 2009


------- Comment #6 from cfleizach at apple.com  2009-02-25 13:43 PDT -------
I will go with getOrCreate. that is a little more explicit than "add", since
most of the time this method is used, it is just to get things. changing get to
getOrCreate will make this a much bigger patch 

(In reply to comment #5)
> (From update of attachment 27954 [review])
> Hey Chris! This patch looks good. My only comments really have to go with
> naming conventions. I am not wild about the names get() and getIfExists(). How
> about one of the following:
> get() = getOrCreate()
> getIfExists() = get()
> or
> get() = add()
> getIfExists() = get()
> The add() one is a little weird, I know, but that is a common naming convention
> for this kind of thing is some other parts of WebCore…basically it means add
> this to the cache or just return it if it already exists. That being said, I
> like getOrCreate() as well, so you can choose whichever you prefer.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list