[Webkit-unassigned] [Bug 32063] ScriptController::isEnabled needs to be renamed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 2 09:42:07 PST 2009


--- Comment #2 from Darin Adler <darin at apple.com>  2009-12-02 09:42:07 PST ---
(In reply to comment #1)
> By the way, given that the argument to FrameLoaderClient::allowJavaScript() is
> called "enabledPerSettings", it may be more appropriate to have the new
> isSandboxed() check outside the parentheses.

Patrik, sorry for sidetracking in your bug.

Alexey, I think the real issue there is whether we want the frame loader client
to be able to override the sandboxing.

If we do want the client to have this capability, and I personally think we do,
then we could change the name of the argument to allowJavaScript. Or consider
other API refinements so the client can make the decision in a well-informed

If we don't, then I think we should change the rules so that ScriptController
won't even call allowJavaScript when sandboxed.

We could look at what clients currently do with the allowJavaScript function to
inform that decision.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list