[Webkit-unassigned] [Bug 32063] ScriptController::isEnabled needs to be renamed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 2 09:38:42 PST 2009


--- Comment #1 from Alexey Proskuryakov <ap at webkit.org>  2009-12-02 09:38:42 PST ---
> Darin Adler suggested 'canExecuteScripts' below. Is that OK?

The name looks good in abstract. Once you post  a final patch, it will be
easier to see if it makes sense at all call sites.

    return m_frame->loader()->client()->allowJavaScript(settings &&
settings->isJavaScriptEnabled() &&

By the way, given that the argument to FrameLoaderClient::allowJavaScript() is
called "enabledPerSettings", it may be more appropriate to have the new
isSandboxed() check outside the parentheses.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list