[Webkit-unassigned] [Bug 27944] Geolocation error callback not called if permissions have already been denied
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Aug 20 13:49:01 PDT 2009
https://bugs.webkit.org/show_bug.cgi?id=27944
Eric Seidel <eric at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #34779|review? |review-
Flag| |
--- Comment #2 from Eric Seidel <eric at webkit.org> 2009-08-20 13:49:00 PDT ---
(From update of attachment 34779)
We don't have a find method for this type?
126 for (GeoNotifierMap::iterator iter = m_watchers.begin(); iter !=
m_watchers.end(); ++iter) {
127 if (iter->second == notifier) {
128 m_watchers.remove(iter);
129 break;
130 }
131 }
Style:
67 if (m_errorCallback) {
68 m_errorCallback->handleEvent(m_fatalError.get());
69 }
No need to store it locally first:
106 RefPtr<PositionError> error =
PositionError::create(PositionError::PERMISSION_DENIED,
permissionDeniedErrorMessage);
107 notifier->setFatalError(error.release());
Aren't the two if (isDenied()) blocks your editing identical? Cant' we share
code there?
Arguments are only named when the name adds clarity:
92 GeoNotifier(Geolocation* geolocation, PassRefPtr<PositionCallback>,
PassRefPtr<PositionErrorCallback>, PassRefPtr<PositionOptions>);
119 void fatalErrorOccurred(GeoNotifier* notifier);
Who would know about this code? I certainly don't.
r- for the seemingly duplicated code.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list