[Webkit-unassigned] [Bug 28080] Adding a bunch of Haiku-specific files for WebCore.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 7 14:46:50 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=28080


Eric Seidel <eric at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #34322|review?                     |review-
               Flag|                            |




--- Comment #6 from Eric Seidel <eric at webkit.org>  2009-08-07 14:46:49 PDT ---
(From update of attachment 34322)
We prefer constants over defines:
 38 #define FIRE_MESSAGE 'fire'

What does "sleepyTime" mean?
 67         bigtime_t sleepyTime = static_cast<bigtime_t>((m_fireTime -
WTF::currentTime()) * 1000000);

bigtime_t sleepTimeInSeconds would be a better name?


This needs a comment:
69         if (sleepyTime < 0)
 70             sleepyTime = 0;

// If the fire time has already passed, fire immediately.
or similar.

Style:
91     BLooper *looper = BLooper::LooperForThread(find_thread(0));

Otherwise this looks sane enough.  You might want to post the new patch on a
new bug, since the other patches were approved.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list